Distributing your apps

PHP is cross-platform. GTK is cross-platform. So, surely it is easy to transfer your code from one platform to another, right? Well, sort of. In order to get PHP-GTK working, you need, unsurprisingly, PHP and GTK installed. Furthermore, if you wish to use Glade, you will also need libglade installed. Naturally, very few Windows users fit this criteria, so you have two options: either you provide very (very!) detailed installation instructions, or you package up the PHP interpreter, any DLLs you want to use, a pre-written php.ini file, and include it all in your installation. This is actually quite a good option, as you can be sure it will work with no hassle for your users, and it only adds around 2MBs to your package once compressed.

For Unix users, generally speaking we're used to software having a few installation requirements, so generally noting on your web-site "Requires PHP4.x, GTK 1.x", etc, should be fine.

However, as you can see in the picture below, our Glade script runs perfectly on Windows. Skins are unavailable in the existing Windows port of GTK, however, so sadly Windows users have to live with a less-than-beautiful interface.

 

Next chapter: Graphical Interfaces Conclusion >>

Previous chapter: GUI Themes

Jump to:

 

Home: Table of Contents

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar