Overly clever modems

Q I recently converted a friend of mine to Linux - Ubuntu to be exact - and he really likes it, but he needs to connect to the web via a Bandrich C-100 modem. I've tried every suggestion on the forums and nothing works - it will not connect. What am I doing wrong? Because of this little glitch there are two other potential users who were going to switch to Linux but who are hesitant now because of this problem.

A The Bandrich C-100 is an Express Card or USB 3G modem that uses the same trickery as the ones mentioned in that feature, presenting itself as a mass storage device (a fake CD-ROM containing the Windows drivers) as well as a modem. This modem is similar to the Novatel modem in the feature, meaning that when the storage device is activated, the modem is hidden. There are three possible ways to fix this. The manual method is to use the eject command to get rid of the fake CD

eject /dev/sr0

at which point the modem should appear as /dev/ttyUSB0. The second option is to let udev handle this for you by adding one of these lines (not both) to etc/udev/rules.d/10-local.rules; create the file if it does not exist.

SUBSYSTEM=="block", ACTION=="add",
SYSFS{idVendor}=="1a8d",
SYSFS{idProduct}=="1002",
OPTIONS="ignore_device"
SUBSYSTEM=="block", ACTION=="add",
SYSFS{idVendor}=="1a8d",
SYSFS{idProduct}=="1002", RUN+="/usr/bin/eject %k"

The first option ignores the fake CD completely, the second ejects it as soon as it appears. Try each of these in turn and one should cause /dev/ttyUSB0 to appear when the modem is plugged in. Once that device appears, you can use any PPP dialler to connect to your ISP. A third option is to try it with the latest Ubuntu release, 8.10. We've tested it previously and found its detection and autoconfiguration of GSM modems to be excellent. There was no need to fiddle with udev rules or dialler scripts - it just worked.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar