Reeepositories

Q I have recently bought an EEE PC 901 and tried to add programs as per a tutorial I read on the internet. All I got was a load of error messages. I assume that the line

deb http://xn4.xandros.com/xs2.0/upkg-srv2 etch main contrib non-free

is on a single line? I tried looking at the web address http://xn4.xandros.com/xs2.0/upkgsrv2 but could not find the directory etch, only dists and pool. I found AbiWord at http://xn4.xandros.com/xs2.0/upkg-srv2/pool/main/a. Where am I going wrong? Has the address changed or do I need to use a different address for the 901?

A The information you have entered looks correct. The address given in sources.list is the parent directory that contains subdirectories for various releases of the distro. The dist directory then contains specific information for those releases; in this case, the Etch and testing releases. The second item on the sources line, Etch in this case, tells the package manager which of the directories in dist to use, and the remaining items say which subdirectories to use, from dists/etch. Some of the repositories for the 900 series are different, but in most cases you can use the same repositories as the 700 series as the software runs on both sets of computers.

It is only a few system packages that are specific to the different Eee variations. It is difficult to be more specific without knowing what the error messages were. Even if they appeared meaningless to you, they contain specific information that helps pinpoint the source of the problem. Were you using the Eee to browse the web addresses, or another computer? If the latter, I suspect a network problem - I have found the wireless handling in the Eee's default Xandros installation to be a little unreliable. I would recommend trying again and capturing the error messages. Get back to us with the details, or post to the forums at www.linuxformat.co.uk, for a more detailed response.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar