USB thumb drive not showing up after OpenSUSE 11 upgrade

Q I have just installed the latest OpenSUSE 11. I kept all my backup files in a thumb drive (/media/disk) before the installation, which completed without any hitches. When I opened the Konsole terminal and tried to change directory by keying cd /media/disk I got this error message:

bash: cd: /media/disk: no such file or directory

The same thing happens when I tried to get to my thumb drive using Konqueror. But I noticed that Dolphin can recognise the thumb drive as 'Volume (vfat)' It is only after I have clicked on the Volume (vfat) icon that I am able to do cd /media/disk using the terminal. The same goes with the Konqueror browser.

A This is normal. It means that your system is set to not automount removable devices when they are connected. The automount system creates the appropriate directory in /media just before mounting the device, and removes it when the device is unmounted - that's why /media/disk does not exist. When you open it in Dolphin, the device is mounted, which is why you can then access it in a terminal. KDE should pop up a notification when a new removable device is connected, with an option to open it in Dolphin. KDE 3 enables you to set an action to be performed automatically when a device is connected (set in the Peripherals > Storage Media section of the KDE Control Centre), though KDE 4 unfortunately doesn't at the time of writing doesn't. However, It isn't a major hassle to open the device in Dolphin before trying to access it from the shell, now that you understand what's going on.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar