Dell and 54g

Q I have a Dell laptop running FC2 with a Netgear WG511 card. I've downloaded and installed the Prism54 driver and firmware, and worked through the Linux Unwired book, setting all the config files, etc. I've also worked through Negus' Linux Bible for FC2, and trawled the net looking for help. The card is set not to come up on boot but on PCMCIA services start. On startup everything works, the eth0 interface comes up, the green light comes on the card and the yellow light flashes encouragingly every now and then. When I start up Mozilla the icon to the bottom right tells me I'm online, but I still can't open any pages - I get an error message saying "not available, check spelling". I'm very happy with my Linux system and am now a Microsoft-free zone, but this is driving me nuts!

A Linux support for 54g Wifi networking is still somewhat nascent, but, that said, your card should be supported by some of the current driver schemes. (Beware though, wifi manufacturers are well-known for changing chipsets even on the same model of card.) If indeed the lights are coming on, particularly the data light, it would seem that at least the card has been detected and has been prompted to communicate, but what you need to do is fathom what exactly the problem is before you attempt to solve it. There are various possibilities -the driver may not be working, the driver may be working but be misconfigured, or the card is configured but the network isn't set up properly, and so on. The wireless tools are very useful for determining if the card is working or not. Just type:

iwconfig

in a terminal. This will list all the known networking devices and either report "no wireless extensions" or give a list of wireless parameters for the card. If your device isn't listed here, then either the correct module isn't loaded (presumably you are using the ndiswrapper method) or it isn't working - probably a driver problem. If the card is listed, you need to check that the parameters are correct. Try looking at the man page for iwconfig for the settings. At the very least you will need to have the ESSID set up, and any encryption key configured to connect to the access point.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar