Nautilus can't access new partition

Q My mum has just got a new digital camera and I have made a partition on /dev/hda2 for all the photos from it. I made it using GParted and everything worked, but when I tried to open the partition, I received an error from Nautilus:

libhal-storage.c 1401 : info: called libhal_free_dbus_error but dbuserror was not set.
process 5222: applications must not close shared connections - see dbus_connection_close() docs.
This is a bug in the application. error: device /dev/hda2 is not removable
error: could not execute pmount

This is the second partition on the disk, and I have tried doing it multiple times both on Ubuntu 8.04 and 64 Studio but I just cannot access the partition. On top of that, I can't access the Ubuntu partition on the first partition of hda1 either. It just gives the same error. PS My girlfriend thinks Linux is boring. Please give me good reason to tell her otherwise!

A There are two messages here, the first two lines are usually caused by your not being in the correct group for automounting, plugdev. You can check which groups you are in by running groups from a terminal. If plugdev is not listed, add yourself to the group with

sudo gpasswd -a username plugdev

You need to run this for your own username and your mum's. If you are already in plugdev, it is likely that this is only a warning and it is the second error that's causing the mount to fail. Most systems now use Pmount to mount removable drives, because it allows devices to be mounted by a user without giving them root access. Because of the security issues involved with this, it is restricted to removable devices. If a device does not report itself as removable, such as a hard disk, Pmount will refuse to mount it. You can override this behaviour by adding the device name to /etc/pmount.allow. Create the file if it does not exist and add /dev/hda2 to it. You can add as many devices as you need, one per line. However, if this is a fixed disk, why you are using automounting in the first place? It may be easier to simply mount the partition somewhere in your directory tree. Create a directory to use as a mount point, say /mnt photos, and add a line to /etc/fstab like

/dev/hda2 /mnt/photos ext3  defaults 0 0

then make sure it is both readable and writable by your user with

chmod username: /mnt/photos

PS You're 14; I'm sure you can find other ways of impressing your girlfriend. Sheesh! Kids these days have no imagination!

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar