Broadcom now working with SUSE on Dell M70 laptop

Q I run OpenSUSE 10.1 on a Dell M70 laptop, but have to use NdisWrapper to get my wireless to work. I have to use Modprobe to activate the wireless, which works a treat. I believe my Dell laptop uses the Broadcom wireless chipset. I would like to use OpenSUSE 10.3 but cannot get the wireless to work - the distro comes with the drivers built-in, but I don't know how to activate the wireless to get it working.

A The Linux kernel now includes native drivers for the Broadcom BCM43xx wireless chipset, but these are reverse-engineered and do not work well with all variants of these chips. I used it with a BCM4306 card and the drivers worked reasonably well, but some of the later chipsets don't work at all (yet). You can see an up to date list of currently supported devices at http://linuxwireless.org/en/users/Drivers/b43 (run lspci in a root terminal to see which version of the hardware you are using). If you have a supported chipset, you should be able to configure it in Yast, though you may need to persuade SUSE to load the driver when you boot. If

lsmod | grep bcm

shows the module as being loaded, you should be OK. Otherwise, do

modprobe bcm43xx

to load it now, and edit /etc/sysconfig/kernel to add bcm43xx to the list of modules in the MODULES_LOADED_ON_BOOT line to have it load automatically at boot time. If you have one of the unsupported chipsets, you'll need to continue to use NdisWrapper, just as you do with SUSE 10.1. In this case, you may need to make sure that the native driver does not try to grab the device first by adding the line

blacklist bcm43xx

to /etc/modprobe.d/blacklist. Then set up NdisWrapper as you've done in SUSE 10.1.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar