Hard drive not being recognised by Mepis and PCLinuxOS

Q I have just bought a Compaq Desktop SR5280CF and tried to use a Live CD. I tried Mepis, PCLinuxOS and OpenSUSE; all three are able to boot in the computer, but the hard disk is not detected. Neither Konqueror nor KDiskFree show hda1 or sda1. This computer comes with Vista and seems to be running OK. Is there anything wrong with this computer or Linux, or is it something I've missed?

A We had the same problem with a new laptop once, and it was down to the SATA settings in the BIOS. Our computer lets you choose whether or not to use AHCI for the SATA interface (Advanced Host Controller Interface is a standard for SATA communication). We have to disable AHCI on the rare occasions that we need to boot Windows (what was that about Linux's inferior hardware support?) and if we forget to re-enable this, Knoppix can't find the hard disk. Ubuntu and Gentoo see the disk, but others do not. Check your BIOS settings and try changing anything related to SATA protocols. Or you can try a different Live CD - Ubuntu worked fine with our system.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar