Screen goes black with Fedora and Nvidia GeForce graphics card

Q I have an AMD64 3000+ CPU, with 1GB of RAM, an Nvidia GeForce PCI-express graphics card and a 320GB SATA HDD. When I install Fedora, everything seems to go well until it gets to 'starting udev [OK]', then the screen goes black. After that, the hard drive seems to continue working, but I can't see anything on the screen, which then delivers this message: 'Mode not supported'. I thought at first it might be the graphics card, but I then installed Elive 0.5, and everything there works. I tried removing the card and using the VIA in-built card, nothing; used a different screen (on the off-chance), nothing.

I tried to boot in all of the options given at the Fedora screen by pressing 'e' but nothing worked. I tried to force the screen resolution (linux resolution=1024x768) and I tried using linux noprobe. The only other error messages that might have some bearing that I can see are: 'PCI: BIOS Bug: MCFG area at e0000000 is not E820-reserved' and 'PCI:Not using MMCONFIG' I don't know if that has anything to do with it, as they don't hinder Elive from working. Can you help me get Fedora to work?

A It sounds to me as though Fedora is trying to use its internal Nvidia driver, and it's struggling to cope with your screen resolution. The quick fix for this problem is to switch over to the VESA driver, which ought to work on pretty much any graphics configuration. If you open up the file /etc/X11/xorg.conf as root, look for this line:

Driver "nv"

Change that to read vesa rather than nv, then reboot. That should at least give you a working Fedora system. Now, if you find that VESA isn't good enough for your day-to-day work, or if you want to try AIGLX or any 3D games, your best bet is to install the official Nvidia driver from www.nvidia.com. This is a great deal more stable than the driver that comes with Fedora, and should solve your problem.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar