USB flash drive not working on some hardware

Q I have a 2GB USB stick on which I have installed Slax Popcorn Edition. I can easily boot my computer from the stick and save all my changes to the system. Once in a while I run into a system where I would really need to boot it from the USB stick but rebooting is not possible, and because the host system is configured 'tight' I can't use Qemu. I have been trying to find the solution to this problem. I tried VMplayer, Qemu and Moka to no avail: there is always something missing. My ultimate solution would be VMplayer installed in the USB stick with the OS image, but I haven't found a way to do this. Is there a solution in the market that would allow me to run my own OS from the USB stick regardless of the host machine?

A There are a number of reasons why you may not be able to boot a USB Flash device on some hardware. Some computers are incapable of booting from USB devices, although these are thankfully few now. Another scenario, which you seem to be experiencing, is that the owner of the computer has configured the BIOS to not boot from USB. If this is the case, trying to circumvent such restrictions is usually wrong and often illegal, unless you have the owner's permission. If you do have the go-ahead, you can often use a bootable CD to start the boot before passing control to the USB device; the Slax website (www.slax.org) contains just such a CD image.

Another obstacle to booting from USB devices is that there are at least three ways of doing this. The device can be set up to boot as if it were a floppy disc, Zip disc or hard disk; the Slax USB installer appears to use the first option. Not all BIOSes can boot all three types, so you may need more than one USB stick. Damn Small Linux has a USB installer capable of creating either a USB-ZIP or USB-HDD-style bootable device, so it may be worth investigating. My laptop will not boot the Slax image but will boot a DSL installation on the same USB key. Some computers will not boot a USB Flash device from a partition larger than 256MB, so you should partition your drive with a 256MB partition for the OS and the rest for your data.

Your VMware solution is ingenious, as it removes the need to reboot, but VMplayer needs files to be installed on the host operating system. Moka would appear to avoid that need, but it works by temporally installing files to the host Windows system, so needs to be run as an administrator. If the configuration of the computer is stopping you from booting a USB device, you should accept that or ask the owner to change it. If it is the way the computer boots from USB devices causing your problem, try a different distro. Mandriva has just announced Mandriva Flash, a complete desktop on a 2GB USB key. I haven't tried it yet - but you can find more information at www.mandriva.com/linux/2007/flash.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar