New version of Kino won't capture video

Q A few days ago I installed Kino using Synaptic on my Ubuntu 6.06, I think the Kino version was 0.8 and it worked very well in all respects, including capturing from my camcorder. Today I accepted the offer of an Ubuntu automatic update to Kino 0.9.2 but when I run Kino now it won't capture. Instead it gives the message:

'Warning: dv1394 kernel module not loaded or failure to read/write /dev/ieee1394/dv/host0/PAL/in'.

My camera shows up correctly as the capture device and Dvgrab from Kino captures without problem (horrible to use) so surely the 1394 must be working. Any ideas on how I can fix this?

A Hmmm. Did you update anything else at the same time? Ubuntu uses udev to manage devices, and at the moment the raw1394 device doesn't play nicely, so it doesn't get created (there is the same problem on Fedora and other distros that now embrace udev more completely). So, that is the likely 'why' As for what you can do about it, an inelegant hack is to merely create the device node yourself:

mknod /dev/raw1394 c 171 0

That should take care of it. If it doesn't, check that the relevant modules are actually being loaded! Running lsmod should tell you if raw1394 and video1394 are loaded properly. You may need to change the permissions on the device to get Kino to read it properly. As a side point, there is much consternation among the distro packagers regarding Kino's insistence on using the raw1394 device. Apart from everything else, relaxing permissions on this device does raise security issues. At some time in the future, Kino may end up using a more regular device to access DV devices.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar