Fedora software installation problem: 'unable to retrieve software information'

Q I have installed Fedora, and all seems fine - with one exception. When I try to run Add/Remove Programs or Packager Updater, I am prompted for the root password. Then I get the error messages: 'Unable to retrieve software information' or 'Unable to retrieve update information'. The only deviation from the default installation is that I do not use the Logical Volume Manager; instead I manually partitioned the hard disk into /boot (100MB), / (38GB) and swap (1024MB). Also, this PC is not connected to the internet. I have tried installation both from CD and from your supplied DVD. But I still get the same errors.

A The lack of an internet connection is the reason for these messages. Both programs try to read information from online software repositories to do their jobs. In the case of the Software Updater, this is inevitable and unavoidable: by their very nature, updates are newer than the packages on the installation media, so it is not possible to use this feature without an internet connection. To prevent this error with Add/Remove Programs, you need to edit the repository files to disable all online sources and add one for the DVD. You need to be root to do this. Load /etc/yum.repos.d/fedora-core.repo into your favourite text editor, find the section starting [core] and comment out the baseurl and mirrorlist lines by placing a # at the start of each line. Then add a new line reading

baseurl=file:///media/disk

This creates a new repository at /media/disk, where the DVD is mounted. You then have to edit the other .repo files and change any occurrences of enabled=1 to enabled=0. Now the only repository that is enabled is the one for the DVD, and running Add/Remove Software should allow you to install software from the disc.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar