Mepis not recognising NFS network

Q I'm enjoying Mepis, especially as it is the first Linux version I've tried in which Skype works well. However, I was disappointed that there was no sign of NFS, meaning I could not use my Linux network. The Mepis website was no help as others have the same problem. So I returned to Kubuntu, which does not seem too different and does most things well (though I regret that Midnight Commander is not available for either system). Can you give me instructions for getting NFS working in Mepis?

A While Mepis comes with NFS enabled in its kernel, it does not have Portmap installed, which is needed to mount NFS partitions. Run Synaptic, go to Settings > Repositories and enable the first entry, the Debian one. Click on Reload to get the latest package lists, then use the Search button to find and install Portmap. You also need to check that the Portmap service is started when you boot - theinstallation should take care of this. You should now be able to mount the NFS export with the standard

mount -t nfs hostname:/exported/dir /mnt/somewhere

If you have already tried, unsuccessfully, to mount this export in the same session, you may need to reboot before it works. NFS can be a little quirky about things like that. Midnight Commander is available for Mepis, once you activate the Debian source that you needed to install Portmap. Again, search in Synaptic and you will find it. The package is called mc.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar