Can't install VMware Player: 'no vmmon modules suitable'

Q I tried to install VMware Player on a Dell Inspiron 5150 laptop. However, I got the message 'no vmmon modules suitable'. I then tried to uninstall the program, but the computer seemed to be in a loop and I aborted after 10 minutes or so. When I run the vm-install.pl program now it gives the message 'Previous installation of VMware software has been detected' and 'Execution aborted'. Any help in clearing the installation and providing a suitable module would be appreciated.

A You don't tell us which Linux distribution you are using, so some parts of this answer will have to be generic rather than specific. Firstly, VMware Player is now installed, which is why you get the message when you try to install it again. Your problem is that it has not been configured, which is done with the vmware-config.pl program (the installer runs this for you when it has finished copying the files). It was vmware-config.pl that gave the 'no vmmon module' error.

VMware Player comes with a wide selection of kernel modules, but it cannot cover every possibility. For example, it has a module for a default SUSE 10.0 installation, but not for Mandriva 2006. If a pre-built module is not present, vmware-config.pl will build one from source, but to do this it needs a C compiler and your kernel source code to be installed. Most distros install a C compiler, but many do not install the kernel source by default. Open your distro's package manager and search for gcc and kernel-source. On some distros, such as Ubuntu, the packages are build-essential and linux-source. Whatever the name, make sure the source package you install matches the version of your running kernel. You can get the version of the current kernel with the command

uname -r

Install whatever is missing and run vmware-config.pl again. This time it should build the modules and everything should be fine from there on.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar