Mouse problems in Fedora

Q I just received your December issue with the Mandrake 10.1 disks. I've installed the system, but for some reason it just won't boot. My computer is home assembled with an AMD CPU, an ATI Rage 128 video board and a two-button mouse on COM2. I have two hard drives: one has SUSE 9.0 and Windows ME in a dual-boot and another that's used for experiments, such as the Mandrake installation. The experimental OSes are run from /dev/hdb. I tried Mandrake 9.2, but the video was distorted and it ran like treacle. I have a feeling that the ATI board may be the problem visually. I tried Fedora, but apparently it couldn't stomach a mouse on COM2 (at least, it never found it) so I couldn't use that either, and I never found out how to tell it where the mouse was. Now Mandrake 10.1, when selected from GRUB, simply returns to reboot. I managed to get something to'take' by using the SUSE vmlinuz and initrd files instead, but there were too many errors for it to finish. Obviously they're incompatible, but the Mandrake ones seem to contain errors. Any ideas please? All offerings gratefully received.

A A reboot immediately after boot generally indicates a kernel issue, and since you have an AMD CPU, it may have complaints with the i686 compiled kernel from Mandrake 10.1. Using the SUSE kernel will allow the box to boot. However, as each vendor has such different kernels, as you've found, it's not always successful. Fedora should be able to function with a mouse on COM2, or ttyS1 in Linux language. In the worst case, you can simply modify your /etc/X11/XF86Config-4 and point it to /dev/ttyS1 rather than /dev/psaux and ensure that the mouse type is set correctly. You may want to purchase a PS/2 or USB mouse with extra buttons because Linux really likes that middle mouse button, and having to click both at the same time gets tiresome very quickly.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar