Cannot write to USB Lacie hard drive in Linux

Q I am using a USB2 160GB Lacie external hard drive, formatted as a primary FAT32 partition. Whenever the disk is connected, an unmounted icon is placed on the desktop, which mounts just fine when I click on it. Unfortunately, I cannot write to it. I checked the relevant permissions and as far as I can see there's no reason why I shouldn't be able to write to it - but it still denies me write access. Ideally I would like to just put the entry for this disk into my /etc/fstab file. I tried to do that with:

/dev /sdb1 /mnt/LACIE vfat 0 0

I have even tried it with fmask=775 and mask=775 but it still won't let me write. Also when I have mounted sdb1 to /mnt/LACIE the automated USB icon gets confused because it wants to mount the device sdb1 to /media/sdb1. I am using Kubuntu with KDE 3.4

A You can try passing the User option to fstab, which will allow the disk to be mounted by a non-root user so that the disk can be written to and read by the user who mounted it. Alternatively, you can pass uid= and gid= statements to set the disk's default UID/GID, although with certain filesystem types, such as ext3 or VFAT, This won't make any difference.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar