USB storage driver issues

Q For some time I have been looking to upgrade from Win98 to Linux, but was reluctant to modify my computer running Win98. A few months ago I was given an old Dell Optiplex with PII processor, 4GB hard disk, 128MB RAM and CDROM drive, running Win95. By a happy coincidence I have a live CDROM of MandrakeMove, and running this showed me that Linux would work on the Dell, and pick up all its features. I used MandrakeMove on the Dell to learn more about Linux, and when you produced a magazine about Fedora, I decided to make the Dell a Linux machine. Loading Fedora went more smoothly than I expected, and more smoothly than some reloads I have done. Later I was given a USB memory stick and found it very useful on my main Win98 machine, so I decided to try it on the Dell.

By this time I had learned enough about Linux to work out what I had to put into the fstab file and the mount point, and it worked on the first boot into Fedora. Now I was really getting bold and decided to see if the USB Zip 250 drive from the other machine worked on the Dell, and loaded MandrakeMove to see if it was detected. There was a success and I deduced that the Zip drive for some reason was /dev/sda4. I put this into the fstab file with a mount point and changed the USB memory stick to sdb1, feeling very clever. It was then that I got into trouble. Fedora saw the Zip drive, which worked, but did not see the USB stick in the other USB slot. I went back to MandrakeMove, but was very disappointed to see that it too saw the Zip drive, and it worked, but it too no longer saw the USB stick. Without the help of a crib from MandrakeMove I am now stuck. Please can you help?

A The USB storage driver, responsible for mounting devices such as USB keyring drives, hard disks, some cameras, optical drives and anything else storage related, has a hard job to do. Part of the problem is the hotplug nature of these devices -they can be attached and removed at any time, and to these ends your drive may not always end up with the same designation, particularly if you plug them in after the system has started. The likelihood is that the drive is being recognised, but is mapped to a different address. The only real way of knowing where it has been put is by looking at the kernel messages. Using:

dmesg

will show you the system messages, but there is a lot of junk in there. However, being cunning, we know what it should say, so we can filter the output:

dmesg | grep 'SCSI device'

This filters the messages to see only the lines that contain text we are interested in. You should see something like:

SCSI device sdb: 128000 512-byte
hdwr sectors (66MB)

Here we can see that the device has been attached as 'sdb' but it could be any other available slot. The reason the Zip uses sda4, or the fourth partition of any drive, is a throwback to the multi-platform support of Iomega devices, which keep special Mac stuff on the first partition.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar