Fedora GRUB problem after installation

Q I am trying to install Fedora as a Samba server for the Win98/ME boxes in my workshop. During installation I receive no messages of anything unusual, but after rebooting it comes to a halt at Grub. It is completely stuck and it's not possible to write anything. I have tried twice with the same result. Setup is System P2 300, 256 of RAM, Drives 3G for the system and 80G for the files. I am only installing X, KDE and the Samba server plus some minor packages. No mail, internet, firewall nor office packages. I am trying to keep it as simple as possible. I started with SUSE Server 9.0 but it started installing the whole Linux world, and uninstalling packages under Linux is not that simple. I'm close to concluding that Linux is a non-productive system.

A This suggests the machine is unable to read the stage1.5 loader. This is often due to a filesystem issue, or because Grub was not installed correctly. You can boot off a Knoppix disk and manually reinstall Grub with the following commands:

# grub
grub> root (hd0,1)
grub> setup (hd0)

This will tell Grub that your / filesystem is on /dev/hda1 and to install the Grub system into /dev/hda. As you have multiple drives, you will have to review your partition assignments before doing this. Once you issue the 'root' command, it will tell you if it can read the stage1.5 and stage2 loaders correctly or not. You may also want to look at installing Fedora, or a distribution such as Mandrake, which is particularly user-friendly. FC3 contains lots of updates to FC2, which may solve your problem without the headache of reinstalling Grub.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar