Segmentation fault when installing Mandriva

Q I managed to get my laptop to install Mandriva 2005, but I'm having a problem installing to my desktop from the DVD version. All seems to go well until reboot then I get a segmentation error and the boot halts. I've tried doing a fresh install with only the keyboard and mouse attached but I get the same error. I've also given Knoppix 3.3 a go on the same machine as specified below and that fires up no problem. The basic machine spec is: Athlon XP2400+XFX KT400ALH mobo, 3/4 gig DDR333 RAM, SBLive, HP PSC2110 printer/scanner, Line 6 GuitarPort, Sync cradle for iPaq, BT Voyager wireless router through the LAN port.

The installation is on to a fresh 20GB drive in a caddy.

A Trying another distribution is often a good way to go, so it's easier to verify if it's a hardware incompatibility issue, or something else. Segmentation faults are generally caused by mismatched library versions, or by bad hardware, but it's worth investigating the problem with Fedora or Ubuntu before going to the hassle of swapping hardware out. Knoppix 3.3 is fairly old and based on a 2.4 kernel, so if you have a copy of Knoppix 3.7 or 3.8 it may help to install that instead so that you're comparing apples with apples.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar