Running Java programs on SUSE Linux

Q I'm trying to install DVDRipper for perfectly legal reasons and it's driving me nuts! I'm using SUSE 9.2 and KDE. Here's what I've done, several times:

1. Copy the folder from the disc to my home directory. 2. Open Konsole. 3. cd to my home directory and to the program's directory that I copied from the disc. 4. Do the tar xzvf thing to the file marked .tar.gz. 5. Konsole lists the contents of the file as DVDripper.jar and README. 6. cd back to the location of DVDRipper.jar. 7. Try ./configure and get the message, 'No such file or directory'.

This is not surprising as the .jar file appears to be an archive in itself. So I tried to tar xzvf the .jar file and got the message:

'gzip stdin has more than one
entry, rest ignored. tar: child
returned status 2 tar: error exit
delayed from previous errors'.

I have also tried to extract the .jar file manually with Ark. Where do I copy it to, and shouldn't it be configured and make installed first?

A As DVDRipper is a Java archive, you don't need to ./configure or install it. Simply cd into the directory containing DVDRipper.jar and run

java -jar DVDRipper.jar

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar