What a turn-off

Q I have installed SUSE 9.2 and have a problem with switching off my Acer laptop. After I select Turnoff from the KDE menu everything goes fine until I receive the message, 'The system will be halted immediately'. After that the system reboots instead of switching off. I have the same situation when trying to use the command line by typing in poweroff as root user. What's surprising is that the problem doesn't exist when I'm using the battery. I didn't have this problem with the Knoppix 3.6 Live CD or Yoper 2.1.0-4 either. If I try the boot options

apm=off acpi=off

it's the same story. When the ptop. After I select computer is shutting down at the end of the process I again get the message, 'The system will be halted immediately', but straight afterwards it reboots anyway. Giving the line

apm=off acpi=off makes the machine hang instead.

I get: 'The system will be halted immediately Master Resource Control: runlevel 0 has been reached Skipped services in runlevel 0:/'.

I installed SUSE in safe mode as well. When I tried to turn off the computer this message appeared: 'The system will be halted immediately Master Resource Control: runlevel 0 has been reached Skipped services in runlevel 0: stty: standard input: unable to perform all requested operations'.

I think I've tried everything, including upgrading BIOS (which supports ACPI) and installing different kernels. SUSE is an excellent distro but with this kind of problems I wouldn't be keen to stick with it.

A Please don't give up on it yet! I think we can help. Disabling both APM and ACPI is probably not a good idea, since it will disable all power management features. Your laptop is probably using ACPI rather than APM for power management, though it depends on the age of the machine, and ACPI in Linux has its fair share of bugs and problems with certain BIOSs. I've known ACPI to allocate IRQs of191to NICs and other crazy stuff, which doesn't make the system very stable. Occasionally tweaking BIOS options will help, but as it works with Knoppix and not with SUSE, I'd err on the side of caution and avoid breaking anything that isn't actually broken. I would suggest instead that you review the boot logs from your system with dmesg and inspect what the kernel finds with respect to your APCI system.

It's not unlikely that it worked under Linux 2.4 and broke in 2.6 kernels. SUSE has kernel updates available now for its 9.2 release, so you may want to give one of those a go and see if you have the same problem. Another place to try is www.linux-laptops.net, where you can find out how other people have installed Linux on to the same laptop. It's worth remembering that many distributions patch their kernels, so if it works with Fedora or Mandrake, it doesn't mean it will work with SUSE. You can always post a bug report with SUSE and find out if they have a work around for a fix for it.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar