SoundBlaster Live not working in SUSE Linux

Q I have a Dell 8300 with a Pentium 4, 1GB of RAM and a 120GB disk running XP Home and two logical partitions running Swap and SUSE 9.2, upgraded from 9.1 Pro, which I bought previously. I had no sound on any SUSE applications and, finding a lack of a driver on the web for the non-standard sound chip supplied by Dell, I bought a standard Sound Blaster Live! digital board. This works fine with XP but not with SUSE. I searched the web again but none of the tips worked. Dell said they didn't support Linux and SUSE installation support said they didn't support sound! I also tried MEPIS Linux kernel 2.6.10 and, run from CD, the sound works fine. I installed MEPIS from the CD, but when it's booted with Grub it won't set up sound as it can't find the motherboard. How can I make SUSE work the Sound Blaster Live! card and why won't the MEPIS system on the hard disk do the same as the MEPIS system on the CD?

A Sound Blaster Live! support in the Linux kernel is provided by the Emu10k1 kernel module, so you may wish to manually load that module using modprobe and investigate what the system does. Run dmesg to output any signs that the kernel picked up your soundcard. You can check with dmesg from MEPIS to find out if it uses the same kernel module and if the sound works as you expect. You can verify within SUSE if it tries to load the kernel module or if it fails to initiate part of the sound system. Output from dmesg would be helpful in resolving this problem, as it's clear to see if the kernel module is loaded, which IRQ (interrupt request line) the soundcard lives on and if there are any conflicts with other devices on the system.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar