BT Home Network 1250 doesn't work under Linux

Q I have been playing around with Linux for about a year, using VMware Workstation on my Windows machine. I know a fair bit about Linux, but I encountered a problem when I decided to install Linux on my real machine. The installation went fine: my problem lies with the network. I have a broadband connection using a BT Home Network 1250 (aka 2Wire Home Portal) connected to a PC, which acts as the router. My machine connects via a BT Home Network PC Adapter (aka 2Wire PC Port) using HomePNA. It works fine on Windows, but there aren't any drivers available for Linux. I have tried NdisWrapper, which just won't work. I am using Fedora. Is there any way I could get my PC port to work with Linux?

A We had a good look around the usual locations for finding information on USB hardware and came up with nothing. We didn't even find anyone saying it didn't work, or even that they had tried and reached a certain point. Our recommendation would be to go with Ethernet, which can be installed either by using Cat5 cable, or by using a pair of powerline adaptors available from D-Link and other vendors.

Follow us on Identi.ca or Twitter

Username:   Password:
Create Account | About TuxRadar